Jak zablokovat facebook?

mikrotik facebook blockblokování facebookuDneska si ukážeme dva způsoby, jak snadno a rychle zablokovat na vašem mikrotiku facebook. Hodí se to zvláště v několika případech. Něko vás naštve, děti se nechtějí učit do školy, manželka místo aby si s váma povídala, tupě čumí na zeď na monitoru. Nemusí se to hodit jen doma, ale i v práci. Jste-li zaměstnavatel, možná ani nevíte že máte jako router mikrotik, zeptejte se vašich IT, oni to nastaví..  Způsoby jsem nevymyslel já, nýbrž google. Proto víte kam psát stížnosti Cool Je jasné že se to nemusí použít pouze na facebook ale i na jiné otravnosti jako je youtube, idnes, tn.cz....

Nezávislý průzkum, který v 16 zemích Afriky, Blízkého východu a Evropy včetně České republiky nechala vypracovat společnost Intel, ukázal, že v Evropě se nejčastěji k sociálním sítím připojují Češi. Čtyři z pěti dotazovaných uživatelů  sociálních sítí z ČR kontrolují svůj status minimálně jednou denně, z toho 5 % častěji než jednou za hodinu, 35 % třikrát až čtyřikrát denně a 41 % jednou denně. Dvě třetiny (67 %) respondentů ze všech zemí uvedly, že kontrolují svůj mobilní přístroj před odchodem do práce a téměř třetina (23 %) tak činí dokonce ještě předtím, než vstanou z postele.

31 % Čechů participujících na průzkumu si kontroluje svá mobilní zařízení už v posteli, dalších 37 % během snídaně či ranní kávy. Pro více než čtyři pětiny (81 %) respondentů z ČR je běžné, že se připojí na internet ještě dříve, než dorazí do práce, zbytek to dožene na pracovišti. Z frekvence přístupu k internetu a k sociálním sítím je zřejmé, že řada uživatelů přistupuje k internetu i z pracovního počítače. (businessworld.cz)

Nyní je potřeba si uvědomit že slovo "kontrolují" znamená klidně 20 minut čumění do monitoru na blbosti. A sám z pracovního života po městských úřadech vím, že to může být mnohem, mnohem víc...

 

Blokování za pomocí Firewall

  1. Spuťte winbox
  2. Klikněte na "New terminal"
  3. Vykopírujte
    /ip firewall filter add chain=forward content="facebook.com" action=drop comment="Drop Facebook"
    /ip firewall filter add chain=forward content="www.facebook.com" action=drop comment="Drop Facebook"
    /ip firewall filter add chain=forward content="apps.facebook.com" action=drop comment="Drop Facebook"
    /ip firewall filter add chain=forward content="facebook" action=drop comment="Drop Facebook"
    /ip firewall filter add chain=forward content="facebook.*" action=drop comment="Drop Facebook"
    
  4. V terminálu klikněte na pravé tlačítko myši zvolte "paste"
  5. Na klávesnici zadejte Enter
  6. Máte hotovo, děti se jdou učit matiku a němčinu Cool
  7. Níže screeny pro toho kdo by si to chtěl třeba naklikat...

jak zablokovat facebook mikrotik

jak zablokovat facebook mikrotik

jak zablokovat facebook mikrotik

jak zablokovat facebook mikrotik

 

Zapomocí Proxy

  1. Spusťte konzoli jak v předchozím případě
  2. Zadejte přikazy
    ip proxy set enabled=yes port=8080 cache-on-disk=no
    ip proxy access add src-address=192.168.56.2/24 dst-host=*.facebook.com action=deny
    ip firewall nat add chain=dstnat  in-interface=ether1 dst-port=80 protocol=tcp action=redirect to-ports=8080
    
  3. A je to. Výhodou je možnost nastavit si třeba danou síť...

Kdo by se tím chtěl proklikat:

    1. IP > Web Proxy
    2. Web Proxy Settings



    1. Červeným křížkem přidat Web Proxy Ruleweb proxy rule



  1. Nyní jděte do IP > Firewall > Nat a Vytvořte pravidlojak zablokovat facebook mikrotikjak zablokovat facebook mikrotik
  2. A Máte hotovo.

Komentáře

10
Obrázek uživatele Martin

navod super ale nastaveni pres proxy nefunguje facebook stale funguje

Obrázek uživatele Martin

Zkoušel jsem oboje nastavení, ale nic se neděje, sice se vytvoří pravidla v sekci firewall, ale facebook jde směle dál.

Obrázek uživatele Ládínek

Zdravím,

obě pravidla stoprocentně fungovaly, testoval jsem je, než jsem to napsal.

Nyní jsem testoval první, jednodušší možnost a fungovala také... viz obrázek

 Blokování facebooku

 

 Neznám situaci u vás, ale máte mikrotik použit jako routr? Nebo jako pouhé AP? Tam by mohl být problém! Jak je vidět na obrázku, v případě proudící komunikace musí být vidět přenesená data u pravidla...

V takovém případě bych třeba doporučil vytvořit jednodušše hotspot a pravidlo by již fungovalo...

Nebo by byla možnost (v závoslosti na prostředí) nastavit na PC které chcete blokovat jako výchozí bránu ip adresu toho vašeho apčka či routeru.

Prostě to blokujte na zařízení které je brána nebo ho z něj udělejte.

Obrázek uživatele nahodný čtenář

Blokování přes firewall mi příjde jako zbytečný zatěžování routerboardu. Kdyby byl aspoň přidán do toho pravidla port 80, aby se tolik netejral. Já si blokování bordelu řeším přes proxy.

K tomu, že mu to nejde, tak vidím problém v něčem jiným. I kdyby mikrotik byl nastavenej komplet v bridge, tak blokováná, přesměrovávání průchozích dat taky funguje, ovšem musí se mu to nakázat a to zapnutím firewalu na bridge příkazem

interface bridge settings set use-ip-firewall yes 

Obrázek uživatele Ládínek

Díky za praktickou radu! Nejsem žádný guru, prodávám jen to co jsem prakticky použil :)

Nicméně při takovém tom domácím routování to jistě není týrání... Ale zátěžovku jsem žádnou nedělal...

Obrázek uživatele Já

Mohl by jste mi prosím váš poradit jak jde zablokovaný facebook zase odblokovat..? Děkuji..

Obrázek uživatele Ládínek

Zakažte vytvořená pravidla ve firewall :)

Obrázek uživatele Michal

Pravidlo ve filtru firewall obejdou okamžitě, protože facebooku se dynamicky přidělují, a teď se podržte, nejrůznější ip adresy z různých koutů světa.  Web proxy obejdou jakmile si spustí facebook v jiné jazykové mutaci než máte nastaveno. No a i kdybyste měly všechny jazykové mutace ve webproxy vypsány, tak vám to obejdou přes https://facebook.com, nebo m.facebook.com a hromada dalších, které se mi tady nechce vypisovat. I když budete mít toto všechno ošetřeno tak vám to zase obejdou přes kproxy, anonymouse, nebo nekonečně mnoho proxyn. Jo a abych nezapomněl i na sítě typu TOR. Tak a co teď? Všechno kromě https a TOR můžete na webproxy zablokovat. Https je na portu 443 takže i když dropnete tento port ve firewallu, nedostanou se zase třeba na email seznamu, nebo do bank atd. Podle mě je nejlepši kombinace webproxy spolu s filtrováním Layer7 protocols a to teda konkrétně pro facebook a proxyny běžící přes https. Zamezit využívání sítí TOR - z toho plyne zamezit instalaci prográmků do počítače. Toto všechno posichrovat přes OpenDNS, nebo i-bezpecne.cz a teprve pak si můžete říct, že snad na chvilku dají pokoj. Ale oni si zase najdou cestičku přes vzdálené plochy jiných PC a to je pořád dokolečka dokola. O pornu se ani nebavím. Ahooj.

Obrázek uživatele [user:name]

Kdyz chcete opravdu zablokovat jednoduse fuckbuck, tak si tam dejte vlastni DNS server a ostatni DNS provoz zablokujte. Na DNS server pridejte zaznam pro fuckbuck.com treba na 127.0.0.1, nezatezujete nic.

Jinak obecne se to da obejit libovolnym tunelem - ssh, ruzne vpnky a proxy, tor nevyjimaje.

Obrázek uživatele Josef práskač

Ne. Tak takhle se to nedělá. doma budiž.

ale v práci jedině tak ze je zakazano komunikovat kamkoliv jinam nezli do vnitrni site kde se take nachazi proxy server. odpadly tim ruzne p2p prasarnicky.

a pouzivam proxy server. tim je problem vyresen.

 

Přidat komentář